ET:QW und TC:E starten nicht

Alles rund um Linux und MAC -Probleme sowie - Fragen hier rein.
Lykos
Grünschnabel
Grünschnabel
Beiträge: 4
Registriert: 15.02.2009, 00:18
Alter:: 28
Kontaktdaten:

ET:QW und TC:E starten nicht

Beitragvon Lykos » 15.02.2009, 00:22

ET:QW und TC:E starten nicht!
Linux, Grafiktreiber installiert.

defusr@linux-ybm4:~> et
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/home/defusr/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: ATI Radeon HD 3870
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found
...GL_NV_fog_distance not found
... GL_EXT_texture_filter_anisotropic not found
Initializing GLX extensions
... GLX_SGI_swap_control not found
... GLX_SGI_video_sync not found
XF86 Gamma extension initialized

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: ATI Radeon HD 3870
GL_VERSION: 1.4 (2.1.8304 Release)
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATIX_texture_env_combine3 GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_texgen_reflection GL_NV_texture_rectangle GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_shadow_ambient GL_SUN_multi_draw_arrays
GLX_EXTENSIONS: GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_OML_swap_method GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap
GL_MAX_TEXTURE_SIZE: 8192
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/defusr/.etwolf/etmain/ui.mp.i386.so)...
Sys_LoadDll(/home/defusr/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/defusr/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/usr/local/games/enemy-territory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at 0xef489f40
Sys_LoadDll(ui) succeeded!
Found high quality video and fast CPU
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: linux-ybm4.site
Alias: linux-ybm4
IP: 127.0.0.2
Started tty console (use +set ttycon 0 to disable)
execing preset_high.cfg
r_colorbits will be changed upon restarting.
r_depthbits will be changed upon restarting.
r_picmip will be changed upon restarting.
r_mode will be changed upon restarting.
r_texturebits will be changed upon restarting.
RE_Shutdown( 1 )
Received signal 11, exiting...
DOUBLE SIGNAL FAULT: Received signal 2, exiting...
Shutdown tty console

Könnt ihr mir helfen? Danke

Benutzeravatar
silver
Admin
Admin
Beiträge: 4731
Registriert: 01.07.2003, 17:35
Wohnort: Castle Wolfenstein
Kontaktdaten:

Beitragvon silver » 15.02.2009, 12:26

also wenn mich jetzt nicht alles täuscht und ich glaub mich täuscht nicht alles, dann ist TCE für et und nicht für quake wars. wir sprechen schon von true combat elite oder?

Lykos
Grünschnabel
Grünschnabel
Beiträge: 4
Registriert: 15.02.2009, 00:18
Alter:: 28
Kontaktdaten:

ET

Beitragvon Lykos » 15.02.2009, 13:23

Jep, du hast recht ET:QW startet normal.
Ich hab mich vertan, ich will aber eigendlich TC:E spielen.
Wolfenstein:ET startet auch nicht, mit ähnlicher Fehlermeldung.
Sorry für Fehlinformation.

Benutzeravatar
tspoon
Moderator
Moderator
Beiträge: 1130
Registriert: 27.12.2002, 03:33
Wohnort: Dresden, im schönen sachsen wo die schönsten mädchen wachsen
Alter:: 39
Kontaktdaten:

Beitragvon tspoon » 16.02.2009, 11:24

haste keinen sound an deine rkiste?

/dev/dsp: Input/output error


da würd ich als erstes suchen.

desweiteren ist singal 11 doch das kill signal für den prozess. eventuell mal in /var/log/messages nachsehen ob da nen fehler zu erkennen ist.

das nächste was er laden würde wäre:

r_clampToEdge


ich würde mir mal ne einge cfg basteln wo antliallising etc aus ist und die auflösung von deinem monitor drin steht und ann mal starten. ich denkmal neben den soundproblen das er mit den atitreiber die 800x600 nicht hinbekommt.[/quote]

Bild
Bild
AMD GAME! Ultra System

______________________________________

Lykos
Grünschnabel
Grünschnabel
Beiträge: 4
Registriert: 15.02.2009, 00:18
Alter:: 28
Kontaktdaten:

No Sound?

Beitragvon Lykos » 16.02.2009, 19:40

Doch doch, Sound hab ich! Ich spiele ET:QW auf 1400x1050 flüssig ;)
Und AA sollte doch standardmaeßig aus sein.
Das mit dem Sound ist so ein Problem, da muss man dann immer mal ein wenig frickeln, dann wird das schon.

Lykos
Grünschnabel
Grünschnabel
Beiträge: 4
Registriert: 15.02.2009, 00:18
Alter:: 28
Kontaktdaten:

Sound

Beitragvon Lykos » 26.02.2009, 10:48

Jep so war es auch... Du hattest recht.
Aber jetzt konnte ich noch nicht einmal die schöne Grafik bewundern, die auf meiner Hardware möglich gewesen wäre. :-(
Die Server, die ich erreichen konnte, wollen mir die ganzen fehlenden Packete nicht geben.
Außerdem ist nur ein Server voll mit spielern, von dem her... als Noob bin ich da gleich wieder gekickt. Schade eigendlich, denn die Screenshots sahen echt geil aus.
THX

Benutzeravatar
WoodSTokk
Helpdesk
Helpdesk
Beiträge: 2615
Registriert: 06.12.2002, 03:09
Wohnort: Wien/Österreich/Europa/Erde
Alter:: 48
Kontaktdaten:

Beitragvon WoodSTokk » 27.02.2009, 12:41

Kill ist es nicht, das wußte ich.
Das Kill-Signal ist 9 (SIGKILL).
Das Term-Signal ist 15 (SIGTERM).

Jetzt hab ich nachgesehen.
Signal 11 = SIGSEGV (Segmentation violation)
Das bekommt man bei Fehler beim Speichezugriff.

Wegen dem Sound:
ET kann nur mit OSS umgehen (sieht man am Devicefile /dev/dsp ).
Wenn bei dir ALSA läuft, musst du nur das Modul snd_pcm_oss laden.

Code: Alles auswählen

sudo modprobe snd_pcm_oss

Dieses Modul gehört zur ALSA und stellt einen OSS-Wrapper für Programme bereit, die mit ALSA nicht umgehen können. Das Modul stellt die OSS-Devicefiles bereit und alles was dort reingeschickt wird, wird an ALSA umgeleitet.
Die Programme bekommen davon nichts mit. Für die Programme sieht es so aus als würden sie normal über OSS abspielen.

mfG WoodSTokk
Du scheisst es nicht zu wetzen
Testserver: @peStable (86.59.121.243:27960)
City-Server: Wolfenstein ciTy Server (195.4.18.203:27960)


Zurück zu „Linux und MAC - Forum“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron